Here is the fourth part of the configuration of our OSPF lab. In this article, we will discuss how to configure OSPF to work on a Frame-Relay network in a Hub & Spoke topology ... 

 Topology of OSPF over Frame-Relay: Non-Broadcast
 
OSPF over Frame-Relay
OSPF over Frame-Relay

The problem
OSPF is an efficient but rigorous protocol. Simple to set up on a LAN or on point-to-point links, it is much more capricious on a Frame-Relay network and especially in a Hub & Spoke topology.
By default, when OSPF is enabled on a Frame-Relay interface, OSPF adapts itself by defining the interface as a "non-broadcast network", which is logical ... since Frame-Relay is indeed a type of NBMA network Non-Broadcast Multi Access). Where things get complicated, it is in the behavior induced by this type of network, namely:
On a Non-Broadcast network:
  • OSPF does not dynamically adjacency
  • OSPF attempts to elect a Designated Router (DR) and a Backup Designated Router (BDR).
The election of a DR and a BDR works perfectly if we are on a Full-Mesh topology that behaves approximately like a LAN Ethernet ... out here we have a Hub & Spoke topology, so no PVC between all the routers, which means that we will have to force ABR4 (the one with a link to the other routers) to be the DR and prevent the other two from becoming BDR.
As a reminder, the DR is the router that serves as centralization for OSPF updates on a shared network. Each router sends its updates to the DR and it then forward them to all routers on the shared network.
First stage
Let's start by configuring the Hub Router "ABR4" ...
First thing, setting the bandwidth of the Serial 0/2 interface. It uses two PVCs, each with a CIR of 128kbit / s, so it will be allocated a bandwidth of 128kbits so that the COST (which will be the same for both is calculated according to this value).
ABR4(config)#interface s0/2

ABR4(config-if)#bandwidth 128

ABR4(config-if)#exit

ABR4(config)#

Then we need to enable OSPF on the Serial0 / 2 interface.
ABR4(config)#router ospf 1
ABR4(config-router)#network 172.16.40.0 0.0.0.255 area 40
ABR4(config-router)#

Since adjacencies will not form dynamically, the neighbors (R2 and R3) must be statically configured.
ABR4(config-router)#neighbor 172.16.40.2
ABR4(config-router)#neighbor 172.16.40.3
ABR4(config-router)#exit

To make sure that ABR4 is the DR of the shared network, it is better to increase its priority (1 by default).
ABR4(config)#int s0/2
ABR4(config-if)#ip ospf priority 127
ABR4(config-if)#exit

That should be enough for ABR4, go to R2 and R3.

Second step
Let's move on to R2. In the same way as for ABR4, we will have to configure statically the neighbor (ABR4). However, in order for the topology to work well, we must ensure that it does not attempt to become DR or BDR. This is equivalent to setting its priority to 0.


R2(config)#interface serial 0/0

R2(config-if)#bandwidth 128

R2(config-if)#ip os

R2(config-if)#ip ospf pr

R2(config-if)#ip ospf prio

R2(config-if)#ip ospf priority 0

R2(config-if)#exit

R2(config)#router ospf 1

R2(config-router)#router-id 8.8.8.8

R2(config-router)#network 172.16.40.0 0.0.0.255 area 40

R2(config-router)#network 192.168.24.1 0.0.0.255 area 40

R2(config-router)#neig

R2(config-router)#neighbor 172.16.40.1

R2(config-router)#exit

R2(config)#exit


Third step
Now only R3 remains to be configured by exactly following the same principle as R2
R3(config)#interface s0/0

R3(config-if)#bandwidth 128

R3(config-if)#ip ospf priority 0

R3(config-if)#exit

R3(config)#router ospf 1

R3(config-router)#router-id 9.9.9.9

R3(config-router)#network 172.16.40.0 0.0.0.255 area 40

R3(config-router)#network 192.168.34.0 0.0.0.255 area 40

R3(config-router)#neighbor 172.16.40.1

R3(config-router)#exit

R3(config)#exit
Fourth step
A priori everything seems to be in order, R3 seems to have a complete routing table. 


R3#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

O IA 192.168.30.0/24 [110/802] via 172.16.40.1, 00:01:09, Serial0/0

O    192.168.24.0/24 [110/791] via 172.16.40.2, 00:01:09, Serial0/0

     192.168.10.0/30 is subnetted, 2 subnets

O IA    192.168.10.0 [110/1563] via 172.16.40.1, 00:01:09, Serial0/0

O IA    192.168.10.4 [110/2344] via 172.16.40.1, 00:01:09, Serial0/0

     172.16.0.0/24 is subnetted, 1 subnets

C       172.16.40.0 is directly connected, Serial0/0

     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks

O IA    10.0.1.8/30 [110/1562] via 172.16.40.1, 00:01:09, Serial0/0

O IA    10.0.1.12/30 [110/1562] via 172.16.40.1, 00:01:09, Serial0/0

O IA    10.0.0.0/24 [110/782] via 172.16.40.1, 00:01:09, Serial0/0

O IA    10.0.1.0/30 [110/1563] via 172.16.40.1, 00:01:09, Serial0/0

O IA    10.0.1.4/30 [110/1563] via 172.16.40.1, 00:01:09, Serial0/0

O IA 192.168.23.0/24 [110/792] via 172.16.40.1, 00:01:10, Serial0/0

C    192.168.34.0/24 is directly connected, FastEthernet0/0

O E1 192.168.100.0/24 [110/2345] via 172.16.40.1, 00:01:10, Serial0/0

R3#


However, looking at the routing table closely, a problem appears. The network 192.168.24.0/24 (The loopback of R2) is accessible via 172.16.40.2, address of the same network as R3 ... except that ... there is no PVC between R2 and R3 and therefore no connectivity between these two Routers!

R3#ping 192.168.24.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.24.1, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

R3#


Since we are in a Hub & Spoke topology, there is no question of creating a new PVC to link these two routers. Therefore, we will have to ask ABR4 to relay the frames frame-relay between R2 and R3 ... This is configured simply by a new frame-relay mapping.
From R2 to join R3, one will use the PVC which leads to R1, and from R3 to join R2 one will also use the PVC which leads to R1.
On R2 ...

R2(config)#interface s0/0

R2(config-if)#frame-relay map ip 172.16.40.3 24 broadcast

R2(config-if)#exit


On R3 ...

R3(config)#interface s0/0

R3(config-if)#frame-relay map ip 172.16.40.2 34 broadcast

R3(config-if)#exit


Verification:


R3#ping 192.168.24.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.24.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 8/45/144 ms

R3#


This time it's good!

In order to be on good OSPF behavior, check the state of ABR4, this should be the DR of the frame-relay network, and R2 and R3 not being DR, nor BDR should be seen as DROTHER.
On ABR4 ...
 

ABR4#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface

3.3.3.3           0   FULL/  -        00:00:32    10.0.1.14       Serial0/1

2.2.2.2           0   FULL/  -        00:00:36    10.0.1.10       Serial0/0

1.1.1.1           1   FULL/BDR        00:00:34    10.0.0.1        FastEthernet0/0

2.2.2.2           1   FULL/DR         00:00:38    10.0.0.3        FastEthernet0/0

3.3.3.3           1   2WAY/DROTHER    00:00:36    10.0.0.4        FastEthernet0/0

8.8.8.8           0   FULL/DROTHER    00:01:32    172.16.40.2     Serial0/2

9.9.9.9           0   FULL/DROTHER    00:01:32    172.16.40.3     Serial0/2

ABR4#


That concludes this article. Now the topology is functional. All that remains is to improve the default behavior, but this will be for the next article. 

                                           Also read  How to configure Multi-area OSPF

 
Top